Feature Releases
RETROSPECTIVES
Adjust image sizes in the RI Analysis section
Allow for images added to the Analysis section of Retrospectives to be re-sized.
Change the incident severity from the Retrospective page
Users now have the flexibility to change the severity of an incident from the Retrospective page. They now have a drop-down to change the incident severity on the Retrospective page, not just on the incident details page.
Prevent Retrospective from being "Published" before the incident is "Resolved"
By default, users can mark a retrospective as "Not Required" or "Published" before the incident has been resolved. A new optional setting under an incident type has been added, which prevents users from changing the state of a retrospective to “Published” or “Not Required” before the corresponding incident is resolved.
Export the entire Retrospective including the analysis section via a public API
Users need the flexibility to export the entire content of a retrospective via a public Blameless API, including the Analysis section.
The "Retrospective Bundle" API returns the following data for a retrospective:
- Summary
- Analysis section
- Customer Questions with the answers
- Impact section: all impact timestamps available at the time of the API call
- Root causes
- Events
- Comments
- Teams
FOLLOW-UP ACTIONS
Add a title field to a FUA
The field previously known as “Description” has been renamed to “Title” to better reflect the purpose of this field. The name of this field has been changed to “Title” when viewing or creating a follow up action in Blameless via any of the following interfaces:
- Blameless Follow Up API
- Slack
- Teams
- Blameless web console (UI).
Select a Jira project when creating follow up actions from Slack
From the Slack incident channel, users can select the project where the Jira ticket gets created as it pertains to follow up actions.
When a user runs `/blameless followup`, the default FUA project is selected in the drop-down, with an option to pick a different JIRA project and Jira issue type.
Automated updates to Statuspage
Statuspage now appears as a provider in the recipients section of the Comms Flow wizard. Updates to Statuspage can be triggered from any of the supported Blameless events (e.g. incident status/severity change), but not as a reminder trigger type. Contact Blameless if you would like to have a preview of this new capability.
Bug Fixes
Timeline events are not wrapping in the Retrospectives PDF export (INC-53)
Issue:
Customer is unable to view the entire code snippet in the PDF export, as it only renders as one line which continues off of the viewable page area and doesn't wrap.
Fix:
Correct text wrap.
FUA Field "Type" marked as optional but should be required (BOTS-418)
Issue:
When creating a Follow-up Action, the "Type" field should be required. It is listed as optional in the Field label.
Fix:
Removed inaccurate label.
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